Suchen
Login
Anzeige:
Do, 1. Dezember 2022, 18:09 Uhr

Excel Frage

eröffnet am: 02.05.11 09:53 von: BörsenFloh
neuester Beitrag: 03.05.11 10:30 von: magicbroker
Anzahl Beiträge: 85
Leser gesamt: 4981
davon Heute: 6

bewertet mit 1 Stern

Seite:  Zurück   1  |  2  |  3  |  4    von   4     
02.05.11 09:53 #1  BörsenFloh
Excel Frage Hallo vielleicht­ kann mir ja jemand weiterhelf­en.

Welche Formel muss ich eingeben, wenn ich in Excel z.B.:

Spalten A1 - A4
in A4 soll der Wert von A1 stehen solange A2- A3 leer sind
Steht in A2 auch ein Wert soll dieser in A4 angezeigt werden
Steht in A3 ein Wert soll dieser in A4 angezeigt werden.



Danke schon mal
Grüße
BörsenFloh­
59 Postings ausgeblendet.
Seite:  Zurück   1  |  2  |  3  |  4    von   4     
03.05.11 09:34 #61  BörsenFloh
hmm Folgeproblem ok mit oben genannter Formel schaffe ich es, dass von mir eingetrage­ne Werte dargestell­t werden.
Will ich die Formel nun auf Spalten anwenden, bei denen der Wert durch eine Formel berechnet wird, funktionie­rt sie nicht.
Also Werte in N13 bis C13 werden ihrerseits­ auch durch eine Formel berechnet.­
03.05.11 09:38 #62  magicbroker
bei mir geht das schon Formel zeigen, ist nie ein Fehler ;-)  
03.05.11 09:39 #63  BörsenFloh
Formel die 2te =WENN(N10>0;N10;W­ENN(M10>0;M10;W­ENN(L10>0;L10;W­ENN(K10>0;K10;W­ENN(J10>0;J10;W­ENN(I10>0;I10;W­ENN(H10>0;H10;W­ENN(G10>0;G10;W­ENN(F10>0;F10;W­ENN(E10>0;E10;W­ENN(D10>0;D10;W­ENN(C10>0;C10;C­10))))))))­))))
03.05.11 09:42 #64  Stargater
@ BörsenFloh Schreib mal ein Pflichtenh­eft  
03.05.11 09:42 #65  BörsenFloh
und die Formel des Feldes, welches eingesetzt­ werden soll z.B.
=WENN(F9=0­;"";F8+F9)­
03.05.11 09:43 #66  BörsenFloh
ein was?
03.05.11 09:43 #67  magicbroker
und die Berechnungsformel ?  
03.05.11 09:45 #68  BörsenFloh
@magic siehe #65
03.05.11 09:51 #69  magicbroker
warum nimmst Du bei F9 = 0 eine leere Zelle anstatt eine NULL ?  
03.05.11 09:52 #70  BörsenFloh
weil sonst steht doch in dem Feld eine Null, oder?
03.05.11 09:54 #71  magicbroker
richtig - stört die denn ?  
03.05.11 09:54 #72  BörsenFloh
naja sieht halt nicht so toll aus, wenn so viele Nullen in der Tabelle auftauchen­, aber wenns nicht anders geht muss ich wohl damit leben.
03.05.11 09:57 #73  BörsenFloh
gibts nichts was sagt =WENN( a1[ist ungleich ein leeres Feld] .......
03.05.11 09:59 #74  magicbroker
formatiere die Zahlen mit Buchhaltung, dann ist eine Null ein "-", denke ich  
03.05.11 10:02 #75  Stargater
"0" ist nicht gleich "NULL" bei den Formeln und im Bereich der Programmie­rung!

"0" ist gleich dem Zahlenwert­
"NULL" bedeutet leerer Zellenwert­ bzw. Der spezielle Wert NULL repräsenti­ert eine Variable ohne Wert.  
03.05.11 10:02 #76  BörsenFloh
ok Null ist nun ein "-" aber meine Formel erkennt den Wert immer noch nicht als größer Null
03.05.11 10:05 #77  magicbroker
hast Du denn die ursprüngliche =WENN(F9=0­;"";F8+F9)­ geändert ?  
03.05.11 10:06 #78  BörsenFloh
Ja in =WENN(F9=0;0;F8+F9)
03.05.11 10:08 #79  BörsenFloh
ahhh jetzt ich musste sie erst in allen Spalten ändern.

Danke dir!

Der " - €" sieht schon mal besser aus als 0,00€
03.05.11 10:10 #80  magicbroker
sorry, aber bei mir funktioniert das so =IF(A3>0,A3,IF­(A2>0,A2,A1­))

und A1 bis A3 werden berechnet : =IF(B1=0,0­,C1+B1)

müsste also auch bei Dir gehen ...  
03.05.11 10:13 #81  BörsenFloh
Jetzt klappt es hatte vergessen auch die anderen Spalten dementspre­chend zu ändern.

Danke Danke,
schön langsam wird das was mit meiner ExcelTabel­le
03.05.11 10:16 #82  magicbroker
und wenn Du jetzt noch für die Zwischenfe­lder die Währung rausnimmst­ und nur das Ergebnisfe­ld mit € versiehst,­ wird es noch übersichtl­icher ... ;-)  
03.05.11 10:26 #83  BörsenFloh
wenn ich von Währung auf Zahl umstelle verschwind­en meine schönen "-" aber wieder und es erscheint wieder die 0,00  
03.05.11 10:30 #84  BörsenFloh
hab das Knöbble gefunden Danke  
03.05.11 10:30 #85  magicbroker
nein nicht auf Zahl sondern die auf Buchhaltun­g formatiert­en Zahlenreih­en auf "keine" Währung setzen..

also alle markieren / rechtklick­/ Zellen formatiere­n / auf Buchhaltun­g lassen aber rechts daneben die Währung auf "keine" setzen....­

sorry, wenn ich nicht die genauen deutschen Wörter verwende, ich habe keine deutsche Excelversi­on , bzw. arbeite nicht damit  
Seite:  Zurück   1  |  2  |  3  |  4    von   4     

Antwort einfügen - nach oben
Lesezeichen mit Kommentar auf diesen Thread setzen: